Difference between revisions of "Getting Started"

From Pavlov VR Wiki
Jump to: navigation, search
m (Bolder a section)
Line 18: Line 18:
 
2. Go to [https://www.epicgames.com/account/connected your Epic Account connections setting page] and fill in your GitHub Account name from the Account you just created. <br />
 
2. Go to [https://www.epicgames.com/account/connected your Epic Account connections setting page] and fill in your GitHub Account name from the Account you just created. <br />
 
3. Once the Accounts are linked, you'll receive an email with a message to "Join @EpicGames" on Github. <br />
 
3. Once the Accounts are linked, you'll receive an email with a message to "Join @EpicGames" on Github. <br />
4. Accept the link and now you should be able to download the tools at [https://github.com/davevill/UnrealEngine/tree/PavlovVRWorkshop the Pavlov Project Template Github Page]. If you want the newest and greatest, “”or are building a map for Pavlov Shack,”” [https://github.com/vankruptgames/PavlovVR-ModKit use these tools instead.] <br />
+
4. Accept the link and now you should be able to download the tools at [https://github.com/vankruptgames/PavlovVR-ModKit the Pavlov Project Template Github Page]. If you want the newest and greatest, “”or are building a map for Pavlov Shack,”” [https://github.com/vankruptgames/PavlovVR-ModKit use these tools instead.] <br />
 
5. Press the green "Clone or Download" button on the right and then press "Download .zip" <br />
 
5. Press the green "Clone or Download" button on the right and then press "Download .zip" <br />
  

Revision as of 20:52, 2 August 2020



Download Unreal Engine

The default layout of the UE4 Editor

1. Register an Unreal Engine Account and download the Unreal Engine Launcher at UnrealEngine.com
2. Once you have downloaded and installed the launcher you need to login with the Account you just created.
3. Go to the "Unreal Engine" Tab and select "Library" on the left. (DO NOT press "Install Engine" as this will install the latest Engine build. Pavlov currently only works with UE4.21.x)
4. In the Libraries window press the "+ Add Engine Version" and select UE4.21.x and press on the yellow "Install" Button. Specify the installation path and continue.
5. The engine will now download and install. Wait for it to finish and proceed with the next step.


If you need further instructions on how to create an Unreal Engine Account and installing the engine please visit the official Unreal Engine Documentation "Installing UE4" website

Download the Pavlov Project Template (Workshop Tools)

1. Create a Github Account at Github.com
2. Go to your Epic Account connections setting page and fill in your GitHub Account name from the Account you just created.
3. Once the Accounts are linked, you'll receive an email with a message to "Join @EpicGames" on Github.
4. Accept the link and now you should be able to download the tools at the Pavlov Project Template Github Page. If you want the newest and greatest, “”or are building a map for Pavlov Shack,”” use these tools instead.
5. Press the green "Clone or Download" button on the right and then press "Download .zip"


If the link doesn't work and you see a 404 Error, please check the settings on your Epic Account and if you are properly logged in on GitHub with the linked Account.

Setting up a new project

Setup Example

1. Extract the "Pavlov.uproject" file, "Config" folder, and "Plugins" folder from the downloaded "UnrealEngine-PavlovVRWorkshop.zip" to your Unreal Project folder (Example: C:\My Documents\Unreal Projects\*ProjectNameHere*\*ExtractedFiles*)

NOTE: Do not rename the Pavlov.uproject.

2. Steam should be open and logged into an Account that owns Pavlov. Completely close and reopen your Epic Games Launcher and open the Pavlov project from the Libraries tab.
3. Wait for the Editor to load (The first time you open UE4, expect it to hang at 45% for about an hour.)
4. In the UE4 Editor, the first thing you have to do is to go to "Window" and select "Pavlov Workshop".
5. In the Pavlov Workshop window, press the "Create New" button once and wait for it to finish. This will create a new and unique UGCXXXXX folder inside the *ProjectNameHere*\Content\CustomMaps folder. Close the window.

NOTE: ALL Assets need to be inside the UGCXXXXX folder otherwise those assets will not be included in the map and won't work ingame later on. DO NOT rename or delete this folder.

6. Create a new Map asset by saving the Untitled template map anywhere inside the UGCXXXXX folder.
7. Open the "Definition" file inside the UGCXXXXX folder and enter a Label (Map Name) and reference the Map file you just saved. You can set a Thumbnail for the map by importing a 512x512 PNG Image file. Do not change the UGC ID. Under Compatibility you can set the gamemodes your map will support.

NOTE: Do not rename or delete the Definition file.

8. Press the Save button and close the window.
9. In the Modes window on the left of the screen, type "Pavlov" into the Search Classes field.
10. Drag and drop a Pavlov Game Logic object anywhere on the map. Place any additional gamemode assets you want as well. (There should already be 1 player spawn placed; you need at least 1 to play the map)

NOTE: If the player spawn says "BAD SIZE", it's too far into the floor and you will fall through the floor when you spawn.

11. Doubleclick the Pavlov Game Logic object you just placed and in the Details tab select the Definition file.
12. Go to File and press Save All. The map should now be ready to Stage or Deploy.

TIP: Every time you open the project you will see a new unsaved, untitled template map. To make UE4 load straight into your actual map, go to Edit, select Project Settings, and in the Default Maps area reference your Map asset in the Editor Startup Map dropdown.


For more information on how to develop a map and how Unreal Engine works, please visit the official Unreal Engine 4 Documentation "Getting Started" website

Migrating an existing map from another UE4 Project

Make sure you followed all the previous steps before doing this.
1. Open the origin project with the Map you want to migrate.
2. Find your Map file in the Content Browser, right click on it, and select "Migrate...".
3. You will see a folder tree with all the referenced files of the map. Press "OK".
4. A Windows Explorer prompt will appear. Select the "Content" folder of your destination Project (Default path is \Users\*winuser*\My Documents\Unreal Projects\) and press "OK".
5. Close the origin project and open the Pavlov project you just migrated to.
6. Move the migrated Map file and all the extra folders that came with it somewhere inside the UGCXXXXX folder. (Click the icon next to the "Seach Folders" field that toggles "Show the Sources Panel". Drag and drop the folders/files inside this panel to move them around.)
7. Right click the Content root folder and select "Fix up redirectors" This will fix all the asset references so they are correctly pointing to each other within the UGCXXXXX folder.


For more information on how to migrate Assets to other Projects, visit the official Unreal Engine 4 Documentation "Migrating Assets" website

Mandatory Entities and their Configuration

Light

Pavlov VR only works with static baked lightning so you have to use a "Directional Light" entity with the "Mobility" set to "Static"
Use a "Skylight" Entity for a realistic outdoor lightning. It also needs to be set to "Static".
For a more realistic look and better clarity in VR set the "Indirect Lightning Intensity" to a value between 2-6.
You can use as many "Point Lights" and "Spot Lights" as you like, as long as they're set to "static"


Spawns

To be able to play your map, you need to have valid Spawnpoints.
Use the "Pavlov Spawn" Entities from the "All Classes" category on the left in the "Modes" window, or use the searchbar at the top of the "Modes" window.
You need to configure them according to the gamemodes you want to support with your map.

Spawnflags
TeamID 0 = Blue Team (Defenders) , 1 = Red Team (Attackers)
Dynamic Tick this for Deathmatch, This prevents spawning inside another person who occupies the spawn area
Only Team Use this Together with the TeamID parameter to only allow for a certain team to spawn. Search & Destroy (S&D) spawns needs this. Uncheck for random Deathmatch spawns
Special Tick this for marking the Spawn to be used for Search & Destroy gamemodes. Use only ONE spawn per Team.. Teams will spawn together at one spawn. Use together with TeamID

When using S&D "Special" spawns, make sure to leave some space to the right of it, as the other 4 Players will spawn in a line next to it.


Protip: Select a spawn and move it above the position where you like it. Then press "END" to drop it to the floor. This will make sure that you'll spawn correctly ingame without falling trough the floor.


Bot Navigation

The Navigation Mesh Visualisation in action

To make the Bots move on your map, you need to add a "Nav Mesh Bounds Volume", which you can find under the "Volumes" Category in the "Modes" Window.
The Volume needs to cover ALL of the walkable space of your map.
Press "P" on your keyboard to get a visual representation of the Navigation Mesh. The green area represents the walkable space for the Bots.
DO NOT make ANY changes to the settings of the volume in the "Details" window, since this will cause the Bots to not move at all.
The Bots will only move between areas that are clearly connected with the Navigation Mesh. (check the "P" Navigation visualisation)
To connect areas that don't connect to eachother but are wide enough to fit a player, you can use a "Nav Link Proxy"
Drag a "Nav Link Proxy" from the "All Classes" category in your map. The Proxy has two beacons that need to touch the green area of the Nav Mesh.
Press "P" to see the bounds and the connection indicator. Align the two beacons so they connect the two Nav Mesh areas. This way you can link a narrow doorway that won't connect to the Nav Mesh.
You can change the Nav Link to be one way by changing the "Link Direction" setting in the "Details" window.


Reflection Captures

A Sphere- and Box Reflection Capture

Reflection Captures are needed to have realistic reflections on all surfaces that are inside the reflection volume.
There are 2 Types of Reflection Captures avaiable. "Box-" and "Sphere Reflection Captures".
The only difference is the shape, so you can adjust the volumes to your level geometry.
Having Reflection Captures in your map prevents shiny and reflective surfaces from looking pitch black ingame. (e.g. Weapons)
Drag and Drop them into your Level from the "Visual Effects" Category of the "Modes" window.
Adjust the size to the aproximate size of your room on eye level.


Bomb Spots

Search & Destroy maps need at least one bombspot. You can have up to 2 seperate bombspots ( A and B ) But you can have as many Bomb Placement Spots for the two Spots.
Drag the "Pavlov Bomb Spot" from the "All Classes" category on the left in the "Modes" window into you map.
By default the Bombspots will be treated as bombspot "A". To change it, simply tick the checkbox "Is B".
The bomb will be placed at the root of the red arrow facing the direction of the arrow. Leave some space between the wall and the arrow, otherwise the Bomb will clip into the wall. (About 5 Units)


Blocking Volumes

Apart from regular walls, sometimes you want to use a "Invisible Wall" for blocking access to a certain area of the map.
To create a "Invisible Wall", drag a "Blocking Volume" from the "Volumes" catergory into your level and scale it to your liking.
The Geometry Editing Tool can also be used on this volume to easily adjust it to your Level Geometry.
Use Blocking Volumes as a ramp over staris to prevent the VR camera from aggressively hopping when walking up stairs.
You can also use them for Smoothing out narrow and busy areas to prevent getting stuck and assure smooth gameplay.


Killing Volumes

Put a "Pavlov Kill Volume" about 1000 - 2000 units under your map, that is a bit bigger than your playspace. This will kill players that somehow fell out of the map or gliched out of it.
You can also use the Kill Volumes for harzardous enviroments in that the Player should die when touching the Volume. (e.g. the front of a moving train or a pool of lava/deep water)


Pavlov Game Logic

You must add this to your level or the Map will not show up ingame.
This object can be placed anywhere in your Map.
Once you place the object in your level, you have to assign the definition file in the object's Details by doubleclicking it.

Ladders

Avoid using ladders if possible, but if you must include them in your map, you can. Overcoming walk-able angle restrictions is possible by using Pavlov Ladder Volumes.
The player will only stick to player-collidable surfaces contained inside the Pavlov Ladder Volume. Avoid overlapping Pavlov Ladder Volumes as this can cause the player to glitch between them.
The Volumes only come as rectangular prisms. To match the shape of a surface that isn't rectangular/square, use many smaller Volumes without overlapping or have a large one that overextends as long as the overextended region isn't encompassing player-collidable surfaces you don't intend to be climbable.

TIP: Work in Player Collision View Mode to better see where the extents of the Volume need to be.

Bullet Penetration - Physical Materials

Show Plugin Content

To enable bullet penetration, you first have to show the Plugin Content. Do this by selecting the View Options in the Content Browser and enabled Show Plugin Content. Next open your material, go into the General tab and select the Phys Material based on the object you're using.
There are two options, normal and thin. Thin will be penetrable.
Physical materials will also change the physics of the objects so metal sounds like metal, wood sounds like wood.

Testing your Map

To test your map, open the "Pavlov Workshop" window by clicking on "Window" > "Pavlov Workshop".
Click on the "Testing" tab and then press the "Stage" button and wait for it to finish. It is finished when the 3 dots stop flashing and the "Stage" button returns.
This will create a local .pak file in your game's "\Pavlov\Content\Paks" folder, so you can load up the map offline for testing.
You can only Stage one map at a time. If you have already Deployed the map to The Workshop, you must be unsubscribed to it before playing a locally staged version of it.

NOTE: Your project won't Stage or Deploy if any asset filepaths exceed 260 characters.
TIP: View your Output Log when you Stage or Deploy to see if any errors or warnings occur. Do this by going to Window > Developer Tools > Output Log.

Submitting and Updating your Map

To make your Map available on Steam, open the "Pavlov Workshop" window by clicking on "Window" > "Pavlov Workshop".
Click on the "Deployment" tab and press the "Submit" button after you typed in some optional but recommended changenotes.
To update the Thumbnail or the Map name, edit the Definition file and press the "Sync Metadata" button on the Setup tab of the "Pavlov Workshop" Window (Where the "Create New" button was before).
By default, the Steam Workshop page is set to "Hidden" and can only be interacted with by it's creators. (You can add people on your Friend's List as creators.) An orange prompt on the page will notify you if it's private still. If you're ready for the map to be available to everybody, set the visibility to "Public".
Just like any other map, you will need to Subscribe to download it. Make sure you delete the local staging .PAK of the map before doing this, if you made one. You may need to restart Steam as well.


TIP: Add some screenshots to your Steam Workshop Page to promote the Map, and be sure the Thumbnail thoroughly represents the Map as it is used in the map selection screen ingame. To add screenshots, visit your Workshop Page on Steam and click on the "Add/edit images & videos" button on the right.

Creating an overhead map image

Add a Camera Actor to your map, preferable high (1000 units roughly) above your map
Rotate the camera -90° on the Y (green) axis so the camera is looking down
Change the Projection Mode to Orthographic
Press G (Game View) which will hide editor stuff
Right click the CameraActor and select Pilot 'CameraActor'
Change the View Mode from Wireframe to Lit
Change the Ortho Width so your whole map is in screen
If you want to remove some ceilings from of the camera, increase the Ortho Near Clip Plane until the ceiling you want to be removed is hidden

For taking a screenshot: Press F11 (Immersion Mode), press the arrow in the top left and choose "High Resolution Screenshot"
Press the camera at the bottom right to create your screenshot. The screenshot will be saved in ../YourProjectName/Saved/Screenshots/Windows/ folder

Stop piloting the CameraActor and delete the CameraActor. If you don't do this, your map will not load.

TIP: Pavlov VR does not use post processing effects, but many of them are on by default in the UE Viewports. You should disable them when Immersion Mode is active.

Troubleshooting

FAQ
The "Create New" Button is missing Steam needs to be open and the used Account needs to have Pavlov purchased. Also check your firewall settings if it blocks any UE4 application
The Map does not update ingame or on the Workshop page Restart Steam, close the Editor and go to your Project folder, delete the "Intermidiate", "Saved" and "Build" folder. Restart the Editor and try updating again
Loading the map ingame leads back to the Lobby Check the Definition file if the map is linked properly
Error "Definition not found" Check if your UGC ID matches the UGC ID in the Definitions file. The definitions file needs to be directly inside of the "UGCXXXXX" folder
Map not loading ingame Check if you have added a Pavlov Game Logic and assigned the definition file to it
Textures or Models are not showing ingame Use "Fix up redirectors" and delete the "Build", "Saved" and "Intermidiate" folder inside the Project folder. Also make sure ALL Assets are inside the UGCXXXXX Folder
I lost my definition file First make sure it's really gone, if it is, add a new Data Asset in the UGCXXXXX folder. Right click in the UGC folder, Miscellaneous > Data Asset > Choose Pavlov_Map > Name it definition (all underscore). Fill in your Unique Id which is your UGC foldername ie. UGC123456789
Nothing happens after I Stage or Deploy Look at the Output Logs window for errors. Window > Developer Tools > Output Logs

If you need further support, check the pinned messages in the workshop channels at Discord.gg/Pavlov-VR[1].

There's also an Unofficial Pavlov Map Making Guide[2] which may be more wordy and up-to-date.



Thanks for Reading!